Skip to content

Which version control systems do you support?

We only support Git repositories from the providers listed below.

On Codacy Cloud we support the following Git providers:

  • GitHub Cloud
  • GitLab Cloud
  • Bitbucket Cloud

Besides these, on Codacy self-hosted we also support:

  • GitHub Enterprise (version 2.20.3 or later)
  • GitLab Enterprise (version 12.6.2-ee or later)
  • Bitbucket Server (version 6.6.0 or later)

Note

Although older versions of the self-hosted Git providers may work with Codacy without loss of functionality, Codacy will only fix issues and ensure compatibility with the versions listed above.

Feedback

Did this page help you?

Thank you for the feedback!

We're sorry to hear that. Please let us know what we can improve.

If you have a question, please contact support@codacy.com.

Last modified December 14, 2020